dotfiles/modules/nixngConfigurations.nix
magic_rb aff0158ef7
Reformat the whole flake using alejandra
Signed-off-by: magic_rb <magic_rb@redalder.org>
2024-03-02 22:17:03 +01:00

34 lines
860 B
Nix

# copied straight from https://github.com/hercules-ci/flake-parts/blob/main/modules/nixosConfigurations.nix
{
lib,
flake-parts-lib,
...
}: let
inherit
(lib)
mkOption
types
literalExpression
;
inherit
(flake-parts-lib)
mkSubmoduleOptions
;
in {
options = {
flake = mkSubmoduleOptions {
nixngConfigurations = mkOption {
type = types.lazyAttrsOf types.raw;
default = {};
description = ''
Instantiated NixNG configurations.
`nixngConfigurations` is for specific machines. If you want to expose
reusable configurations, add them to [`nixosModules`](#opt-flake.nixosModules)
in the form of modules (no `lib.nixosSystem`), so that you can reference
them in this or another flake's `nixngConfigurations`.
'';
};
};
};
}