dotfiles/home-manager/modules/dunst/default.nix
magic_rb aff0158ef7
Reformat the whole flake using alejandra
Signed-off-by: magic_rb <magic_rb@redalder.org>
2024-03-02 22:17:03 +01:00

20 lines
493 B
Nix

{pkgs, ...}: {
home.file.".config/dunstrc".source = ./dunstrc;
systemd.user.services.dunst = {
Unit = {
Description = "Dunst notification daemon";
After = ["graphical-session-pre.target"];
PartOf = ["graphical-session.target"];
};
Service = {
Type = "dbus";
BusName = "org.freedesktop.Notifications";
ExecStart = "${pkgs.dunst}/bin/dunst -config ~/.config/dunstrc";
};
Install = {WantedBy = ["graphical-session.target"];};
};
}